Package: jupyter-notebook / 5.7.8-1

Metadata

Package Version Patches format
jupyter-notebook 5.7.8-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0011 use system po2json.patch | (download)

setupbase.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use po2json from package for translations
0001 Nodejs binary and import names.patch | (download)

setupbase.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 nodejs binary and import names

 * Binary node -> nodejs

0002 Use local MathJax in documentation.patch | (download)

docs/source/conf.py | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 use local mathjax in documentation


0003 jquery ui 1.12 compatibility changes.patch | (download)

notebook/templates/page.html | 1 0 + 1 - 0 !
tools/build-main.js | 1 0 + 1 - 0 !
2 files changed, 2 deletions(-)

 jquery-ui 1.12 compatibility changes


0004 Call lessc with source map basepath option for repro.patch | (download)

setupbase.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 call lessc with --source-map-basepath option for reproducibility


0005 Work around https github.com less less.js pull 3002.patch | (download)

setupbase.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 work around https://github.com/less/less.js/pull/3002


0006 Debian specific hack to fix upstream s non increment.patch | (download)

setup.py | 27 15 + 12 - 0 !
1 file changed, 15 insertions(+), 12 deletions(-)

 debian-specific hack to fix upstream's (non-)incremental build


0007 Ignore errors in documentation notebooks during buil.patch | (download)

docs/source/conf.py | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 ignore errors in documentation notebooks during build


0009 Don t try and patch bootstrap less.patch | (download)

setupbase.py | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 don't try and patch bootstrap less

setupbase.py tries to patch out one line from bootstrap's less, to
improve printing. In this case we're not using a private copy of this
file, so we can't modify the system copy.

TODO: Find an alternative way of implementing this fix.

0010 xterm legacy.patch | (download)

notebook/static/terminal/js/terminado.js | 9 2 + 7 - 0 !
1 file changed, 2 insertions(+), 7 deletions(-)

 compatibility changes for an older version of xterm
0012 use term.js.patch | (download)

bower.json | 4 1 + 3 - 0 !
notebook/static/terminal/js/main.js | 2 1 + 1 - 0 !
notebook/static/terminal/js/terminado.js | 2 1 + 1 - 0 !
notebook/templates/page.html | 2 1 + 1 - 0 !
setupbase.py | 4 1 + 3 - 0 !
tools/build-main.js | 2 0 + 2 - 0 !
6 files changed, 5 insertions(+), 11 deletions(-)

---