Package: kde4libs / 4:4.14.2-5+deb8u2

findqt4_optional_x11_pthread.diff Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Qt doesn't expose the X11 headers to the world, so no need to make it required.
---
 cmake/modules/Qt4ConfigDependentSettings.cmake |    3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

--- a/cmake/modules/Qt4ConfigDependentSettings.cmake
+++ b/cmake/modules/Qt4ConfigDependentSettings.cmake
@@ -27,10 +27,9 @@
 IF(UNIX)
   # on OS X X11 may not be required
   IF (Q_WS_X11)
-    FIND_PACKAGE(X11 REQUIRED)
+    FIND_PACKAGE(X11)
   ENDIF (Q_WS_X11)
   FIND_PACKAGE(Threads)
-  SET(QT_QTCORE_LIBRARY ${QT_QTCORE_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
 ENDIF(UNIX)