Package: latex-mk / 2.1-1.3

Metadata

Package Version Patches format
latex-mk 2.1-1.3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
gmake subst run tests.patch | (download)

testsuite/run_tests.sh | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 make "make check" work
use fancyhdr.patch | (download)

example/ex2.tex | 2 1 + 1 - 0 !
example/ex3.tex | 2 1 + 1 - 0 !
example/ex4.tex | 2 1 + 1 - 0 !
example/ex5.tex | 2 1 + 1 - 0 !
example/example.tex | 2 1 + 1 - 0 !
testsuite/texfiles/bibliography.tex | 2 1 + 1 - 0 !
testsuite/texfiles/bibliography2.tex | 2 1 + 1 - 0 !
testsuite/texfiles/index.tex | 2 1 + 1 - 0 !
testsuite/texfiles/nomencl.tex | 2 1 + 1 - 0 !
9 files changed, 9 insertions(+), 9 deletions(-)

 use fancyhdr.sty instead of fancyheadings.sty
#  fancyheadings.sty cannot be found in TeXLive
new nomencl.patch | (download)

testsuite/texfiles/nomencl.tex | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 make one of the tests work with a recent version of nomencl.sty
use gunzip instead of gzcat.patch | (download)

latex.mk.in.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use gunzip -c instead of gzcat
disable tgif.patch | (download)

latex.mk.in.in | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 disables build dependency on tgif
 tgif was removed from testing for various reasons.
 First, its dependencies are not in testing (see https://bugs.debian.org/699301)
 and then its own status is ambiguous (see https://bugs.debian.org/668249).
 This patch disables tgif-related functionality by showing error
 message if the user wants to use it.
 .
 latex-mk (2.1-1.3) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * Disable support and dependency on tgif (Closes: #768690)