Package: lava / 2019.01-5

Metadata

Package Version Patches format
lava 2019.01-5 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Fix typo in f6bb9de2.patch | (download)

lava_scheduler_app/views.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix typo in f6bb9de2

result links all show invalid_test_name
https://git.lavasoftware.org/lava/lava/issues/204

Signed-off-by: Neil Williams <neil.williams@linaro.org>

0002 Require python3 junitxml 1.8 for REST API calls.patch | (download)

share/requirements/debian/stretch-backports.yaml | 3 3 + 0 - 0 !
share/requirements/debian/stretch.yaml | 2 0 + 2 - 0 !
2 files changed, 3 insertions(+), 2 deletions(-)

 require python3-junitxml >= 1.8 for rest api calls

Depend on the version in stretch-backports.
https://git.lavasoftware.org/lava/lava/issues/209

Signed-off-by: Neil Williams <neil.williams@linaro.org>

0003 Fix crash with older python3 tap versions.patch | (download)

lava_rest_app/api.py | 8 7 + 1 - 0 !
lava_rest_app/tests.py | 26 26 + 0 - 0 !
2 files changed, 33 insertions(+), 1 deletion(-)

 fix crash with older python3-tap versions
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit

Closes https://git.lavasoftware.org/lava/lava/issues/211

Signed-off-by: RĂ©mi Duraffort remi.duraffort@linaro.org