Package: libanyevent-perl / 7.140-3

Metadata

Package Version Patches format
libanyevent-perl 7.140-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix spelling.patch | (download)

lib/AnyEvent.pm | 10 5 + 5 - 0 !
lib/AnyEvent/DNS.pm | 2 1 + 1 - 0 !
lib/AnyEvent/Debug.pm | 6 3 + 3 - 0 !
lib/AnyEvent/Handle.pm | 8 4 + 4 - 0 !
lib/AnyEvent/Impl/IOAsync.pm | 2 1 + 1 - 0 !
lib/AnyEvent/Intro.pod | 6 3 + 3 - 0 !
lib/AnyEvent/Log.pm | 2 1 + 1 - 0 !
lib/AnyEvent/TLS.pm | 2 1 + 1 - 0 !
8 files changed, 19 insertions(+), 19 deletions(-)

 fix a spelling error found by lintian
replace abuse die with warn.patch | (download)

lib/AnyEvent.pm | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 replace hardcoded die by a warn if io::async::loop::anyevent is in use
dh 2048.patch | (download)

lib/AnyEvent/TLS.pm | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 use 2048-bit dh keys by default.
 It is a sensible size nowadays; also, the Debian package of OpenSSL 1.1
 no longer accepts smaller DH keys in its default configuration.
Bug-Debian: https://bugs.debian.org/923615