Package: libapache-poi-java / 3.10.1-3

Metadata

Package Version Patches format
libapache-poi-java 3.10.1-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01_disable code coverage.patch | (download)

build.xml | 28 10 + 18 - 0 !
1 file changed, 10 insertions(+), 18 deletions(-)

 disables the code coverage report (jacoco isn't available in debian)
04_jar_names.patch | (download)

build.xml | 12 6 + 6 - 0 !
1 file changed, 6 insertions(+), 6 deletions(-)

 remove ${dstamp} suffix added to jars
05_use local ooxml xsds.patch | (download)

build.xml | 5 2 + 3 - 0 !
1 file changed, 2 insertions(+), 3 deletions(-)

 patch to use the local ooxml schema instead of fetching the files from the ecma site at build time
06_java8 compatibility.patch | (download)

src/java/org/apache/poi/ss/util/DateFormatConverter.java | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 fixes a build failure with java 8
07_CVE 2014 9527.patch | (download)

src/scratchpad/src/org/apache/poi/hslf/HSLFSlideShow.java | 97 59 + 38 - 0 !
1 file changed, 59 insertions(+), 38 deletions(-)

 fix an infinite loop on corrupted ppt file (cve-2014-9527).
 This patch can be dropped after upgrading to Apache POI 3.11 or later.