Package: libdbd-mysql-perl / 4.028-2+deb8u2

Metadata

Package Version Patches format
libdbd-mysql-perl 4.028-2+deb8u2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
pod whatis.patch | (download)

README.pod | 4 3 + 1 - 0 !
1 file changed, 3 insertions(+), 1 deletion(-)

 fix pod to get a whatis entry after pod2man
CVE 2014 9906.patch | (download)

dbdimp.c | 11 8 + 3 - 0 !
1 file changed, 8 insertions(+), 3 deletions(-)

 cve-2014-9906: fix use-after-free flaw
CVE 2015 8949.patch | (download)

dbdimp.c | 9 4 + 5 - 0 !
1 file changed, 4 insertions(+), 5 deletions(-)

 cve-2015-8949: use after free when my_login fails
CVE 2016 1246.patch | (download)

dbdimp.c | 6 3 + 3 - 0 !
1 file changed, 3 insertions(+), 3 deletions(-)

 [patch] do not use unsafe sprintf w/variable length input

This can cause a  buffer overflow to occur when reporting
error message about validation of (untrusted) user input parameters.