Package: libgovirt / 0.3.4-3.1

Metadata

Package Version Patches format
libgovirt 0.3.4-3.1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
update_certs | (download)

tests/https-cert/ca-cert.pem | 50 20 + 30 - 0 !
tests/https-cert/ca-key.pem | 77 25 + 52 - 0 !
tests/https-cert/server-cert.pem | 51 23 + 28 - 0 !
tests/https-cert/server-key.csr | 50 25 + 25 - 0 !
4 files changed, 93 insertions(+), 135 deletions(-)

 regenerate test certificates
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=915270

Tests fail because test certificates are now expired. This patch
regenerates them with expiration date in a century (I'll remember
to ask my grandchildren to regenerate them before then in my
will).

Useful information about how to regenerate: https://datacenteroverlords.com/2012/03/01/creating-your-own-ssl-certificate-authority/
(but I doubt my granchildren will be able to still see that
page).