Package: libgtkada / 18-2

update-gtk-gir.diff Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
Description: attempt to use obsolete Gtk-3.0.gir with recent libgtk-dev
 Gtk-*.gir is generated then manually patched by upstream,
 so it cannot be updated cleanly.
 .
 The main gtk loop now passes BELOW_TEXT=2 and ABOVE_TEXT=3 instead of
 BELOW=0 and ABOVE=1, causing Constraint_Error: invalid data in callbacks.
Author: Nicolas Boulenguez <nicolas@debian.org>

--- a/contrib/Gtk-3.0.gir
+++ b/contrib/Gtk-3.0.gir
@@ -108509,13 +108509,23 @@
               value="0"
               c:identifier="GTK_TEXT_VIEW_LAYER_BELOW"
               glib:nick="below">
-        <doc xml:space="preserve">The layer rendered below the text (but above the background).</doc>
+        <doc xml:space="preserve">Old deprecated layer, use GTK_TEXT_VIEW_LAYER_BELOW_TEXT instead</doc>
       </member>
       <member name="above"
               value="1"
               c:identifier="GTK_TEXT_VIEW_LAYER_ABOVE"
               glib:nick="above">
-        <doc xml:space="preserve">The layer rendered above the text.</doc>
+        <doc xml:space="preserve">Old deprecated layer, use GTK_TEXT_VIEW_LAYER_ABOVE_TEXT instead</doc>
+      </member>
+      <member name="below_text"
+              value="2"
+              c:identifier="GTK_TEXT_VIEW_LAYER_BELOW_TEXT">
+        <doc xml:space="preserve">The layer rendered below the text (but above the background).</doc>
+      </member>
+      <member name="above_text"
+              value="3"
+              c:identifier="GTK_TEXT_VIEW_LAYER_ABOVE_TEXT">
+        <doc xml:space="preserve">The layer rendered above the text. Since: 3.20</doc>
       </member>
     </enumeration>
     <record name="TextViewPrivate" c:type="GtkTextViewPrivate" disguised="1">