Package: libjpeg6b / 1:6b2-3

Metadata

Package Version Patches format
libjpeg6b 1:6b2-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
extern_C jpeglib.h | (download)

jpeglib.h | 8 8 + 0 - 0 !
1 file changed, 8 insertions(+)

 wrap jpeglib.h with extern "c" {} if __cplusplus is defined.
 Wrap jpeglib.h inside extern "C" { ... } if the compiler
 defines __cplusplus.
use autotools dev | (download)

config.guess | 5 5 + 0 - 0 !
config.sub | 5 5 + 0 - 0 !
2 files changed, 10 insertions(+)

 tweak config.guess/sub to use the autotools-dev version 
 Tweak config.guess/sub to use the autotools-dev version if available.
automake Wno obsolete | (download)

configure.ac | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 automake 1.11 needs -wno-obsolete due to ansi2knr (for autoreconf)
 or fails with message 'automatic de-ANSI-fication support is deprecated'.