Package: libmems / 1.6.0+4725-8

Metadata

Package Version Patches format
libmems 1.6.0+4725-8 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01_fix_ctors.patch | (download)

libMems/Aligner.cpp | 2 1 + 1 - 0 !
libMems/Aligner.h | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 fix ctors of {matchleftend,labeledmem}comparator to enable sort/3 with g++-4.9


02_fix_a_Wformat.patch | (download)

libMems/dmSML/dmsort.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix a -wformat (boy, that's a bloody serious error)


pkg config directive.patch | (download)

configure.ac | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix lintian error
  E: libmems-1.6-dev: pkg-config-bad-directive usr/lib/x86_64-linux-gnu/pkgconfig/libMems-1.6.pc -Wno-deprecated
 by not appending "-Wno-deprecated"


03_update_boost_m4_to_git_d9ff75.patch | (download)

m4/boost.m4 | 107 103 + 4 - 0 !
1 file changed, 103 insertions(+), 4 deletions(-)

 updates the boost.m4 file to correct problems with gcc-5
 This patch updates the m4/boost.m4 file to the  git version d9ff75
 of boost.m4 upstream 
 .
04_add_dependend_libs_to_link_command.patch | (download)

libMems/Makefile.am | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 add some dependencies to the linker command  
05_gcc 6.patch | (download)

libMems/ProgressiveAligner.cpp | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 correct compilation with g++-6
boost1.62.patch | (download)

libMems/AbstractMatch.h | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 fix ftbfs with boost 1.62
 Add missing include so that BOOST_WORKAROUND is defined.
drop version number.patch | (download)

Makefile.am | 2 1 + 1 - 0 !
configure.ac | 4 2 + 2 - 0 !
libMems-1.6.pc.in | 12 0 + 12 - 0 !
libMems.pc.in | 12 12 + 0 - 0 !
libMems/Makefile.am | 14 7 + 7 - 0 !
libMems/dmSML/Makefile.am | 2 1 + 1 - 0 !
6 files changed, 23 insertions(+), 23 deletions(-)

 drop version number from library file name