Package: libopenhmd / 0.2.0-5

pkg-config-Substitute-the-correct-libdir-includedir.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
From: Simon McVittie <smcv@debian.org>
Date: Wed, 17 Oct 2018 17:52:15 +0100
Subject: pkg-config: Substitute the correct libdir, includedir

Libraries are not always installed in ${prefix}/lib, and pkg-config
metadata is not always in ${prefix}/lib/pkgconfig.

Origin: vendor, Debian
---
 pkg-config/openhmd.pc.in | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/pkg-config/openhmd.pc.in b/pkg-config/openhmd.pc.in
index 00d7331..575a061 100644
--- a/pkg-config/openhmd.pc.in
+++ b/pkg-config/openhmd.pc.in
@@ -1,6 +1,7 @@
-prefix=${pcfiledir}/../..
-libdir=${prefix}/lib
-includedir=${prefix}/include/openhmd
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@/openhmd
 
 Name: openhmd
 Description: API and drivers for immersive technology devices such as HMDs