Package: libsbml / 5.17.2+dfsg-3

Metadata

Package Version Patches format
libsbml 5.17.2+dfsg-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
perl installdirs.patch | (download)

src/bindings/perl/CMakeLists.txt | 10 8 + 2 - 0 !
src/bindings/perl/Makefile.PL.in | 1 0 + 1 - 0 !
2 files changed, 8 insertions(+), 3 deletions(-)

 install perl modules in correct dir


hardening.patch | (download)

config/makefile-common-actions.mk | 9 9 + 0 - 0 !
src/bindings/matlab/Makefile.in | 2 1 + 1 - 0 !
src/bindings/perl/Makefile.in | 1 1 + 0 - 0 !
3 files changed, 11 insertions(+), 1 deletion(-)

 hardening
 .
 libsbml (5.11.0+dfsg-1sid1) UNRELEASED; urgency=medium
 .
   * update from upstream
doxygen.patch | (download)

docs/CMakeLists.txt | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix a wrong file name
 docs/CmakeLists.txt contains a wrong path to right-arrow-2x.png
 .
 libsbml (5.11.0+dfsg-1sid1) UNRELEASED; urgency=medium
 .
   * update from upstream
swig 3.x.patch | (download)

src/bindings/csharp/local-packages-arrays.i | 8 4 + 4 - 0 !
src/bindings/csharp/local-packages-groups.i | 8 4 + 4 - 0 !
src/bindings/csharp/local-packages-layout.i | 8 4 + 4 - 0 !
src/bindings/csharp/local-packages-render.i | 8 4 + 4 - 0 !
src/bindings/csharp/local-packages-req.i | 8 4 + 4 - 0 !
src/bindings/csharp/local-packages-spatial.i | 8 4 + 4 - 0 !
src/bindings/csharp/local.i | 86 43 + 43 - 0 !
7 files changed, 67 insertions(+), 67 deletions(-)

 build with swig 3.x


mips compile with O1.patch | (download)

src/bindings/perl/CMakeLists.txt | 6 6 + 0 - 0 !
1 file changed, 6 insertions(+)

 package libsbml ftbfs on mipsel
 We have successfully built libsbml using -O1 optimization level.
 -O1 is used for mips/mipsel, for critical part of package.
 .
 With this patch we was able to build package on lemote loongson 3a.


javadoc_java9.patch | (download)

docs/CMakeLists.txt | 4 0 + 4 - 0 !
1 file changed, 4 deletions(-)

 work around javadoc issue with java 9
  See https://lists.debian.org/debian-java/2018/03/msg00023.html
Bug-Debian: https://bugs.debian.org/893298
javadoc.patch | (download)

docs/src/SBMLDoclet.java | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 deal with issue in doclets
  /build/libsbml-5.16.0+dfsg/docs/src/SBMLDoclet.java:112: error: package com.sun.tools.doclets.standard is not visible
 import com.sun.tools.doclets.standard.Standard;
                             ^
   (package com.sun.tools.doclets.standard is declared in module jdk.javadoc, which does not export it)
 .
 This web page brought the idea for the patch:
   https://docs.oracle.com/javase/9/docs/api/com/sun/javadoc/class-use/LanguageVersion.html
remove_SBMLDoclet.patch | (download)

docs/CMakeLists.txt | 63 3 + 60 - 0 !
docs/src/SBMLDoclet.java | 525 0 + 525 - 0 !
2 files changed, 3 insertions(+), 585 deletions(-)

 deal with issue in doclets by removing docs/src/sbmldoclet.java
Bug-Debian: https://bugs.debian.org/896531
fix_cmake_configuration.patch | (download)

src/bindings/r/CMakeLists.txt | 7 6 + 1 - 0 !
1 file changed, 6 insertions(+), 1 deletion(-)

 desperately trying to fix cmake config by simply
 commenting the line which causes an error


fix_build_issue.patch | (download)

src/bindings/swig/swigdoc.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 avoid error
   TypeError: '>=' not supported between instances of 'str' and 'int'