Package: lttng-modules / 2.9.0-1+deb9u1

Metadata

Package Version Patches format
lttng-modules 2.9.0-1+deb9u1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix linux rt 4.9 sched.patch | (download)

instrumentation/events/lttng-module/sched.h | 21 20 + 1 - 0 !
1 file changed, 20 insertions(+), 1 deletion(-)

---
update kvm instrumentation for 4.15.patch | (download)

instrumentation/events/lttng-module/kvm.h | 18 18 + 0 - 0 !
1 file changed, 18 insertions(+)

 [patch] update kvm instrumentation for 4.15

Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>

update kvm instrumentation for debian kernel 4.9.65 3.patch | (download)

instrumentation/events/lttng-module/kvm.h | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 [patch] update kvm instrumentation for debian kernel 4.9.65-3

Signed-off-by: Michael Jeanson <mjeanson@efficios.com>
Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>

fix debian kernel version parsing.patch | (download)

abi-debian-version.sh | 18 10 + 8 - 0 !
1 file changed, 10 insertions(+), 8 deletions(-)

 [patch] fix: debian kernel version parsing

The debian version script only worked for ckt kernels and that was fine
until now because we only had checks for those versions in the code.

ckt (Canonical Kernel Team) kernels were used for a while during the jessie