Package: lua-sec / 0.7-1~bpo9+1

Metadata

Package Version Patches format
lua-sec 0.7-1~bpo9+1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 test.patch | (download)

test.lua | 2 2 + 0 - 0 !
test.sh | 13 13 + 0 - 0 !
2 files changed, 15 insertions(+)

 test


0002 lua sec.h.patch | (download)

lua-sec.h | 9 9 + 0 - 0 !
1 file changed, 9 insertions(+)

 lua-sec.h


0003 use 2048 bit RSA keys and sha256 instead of 1024 bit.patch | (download)

samples/certs/clientA.bat | 4 2 + 2 - 0 !
samples/certs/clientA.cnf | 4 2 + 2 - 0 !
samples/certs/clientA.sh | 4 2 + 2 - 0 !
samples/certs/clientB.bat | 4 2 + 2 - 0 !
samples/certs/clientB.cnf | 4 2 + 2 - 0 !
samples/certs/clientB.sh | 4 2 + 2 - 0 !
samples/certs/rootA.bat | 4 2 + 2 - 0 !
samples/certs/rootA.cnf | 4 2 + 2 - 0 !
samples/certs/rootA.sh | 4 2 + 2 - 0 !
samples/certs/rootB.bat | 4 2 + 2 - 0 !
samples/certs/rootB.cnf | 4 2 + 2 - 0 !
samples/certs/rootB.sh | 4 2 + 2 - 0 !
samples/certs/serverA.bat | 4 2 + 2 - 0 !
samples/certs/serverA.cnf | 4 2 + 2 - 0 !
samples/certs/serverA.sh | 4 2 + 2 - 0 !
samples/certs/serverB.bat | 4 2 + 2 - 0 !
samples/certs/serverB.cnf | 4 2 + 2 - 0 !
samples/certs/serverB.sh | 4 2 + 2 - 0 !
samples/dhparam/params.sh | 2 1 + 1 - 0 !
samples/dhparam/server.lua | 4 2 + 2 - 0 !
20 files changed, 39 insertions(+), 39 deletions(-)

 use 2048-bit rsa keys and sha256 instead of 1024-bit rsa and sha1

According to Kurt Roeckx in https://bugs.debian.org/906997, the test
suite is failing when built against libssl 1.1.1 because we require at
least 2048-bit keys.

We also move from sha1 to sha256, as we're updating our cryptographic
primitives.