Package: magics++ / 4.5.3-1

paths.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Description: Use system perl, not path, for safety
Author: Alastair McKinstry <mckinstry@debian.org>
Last-Updated: 2018-11-15
Forwarded: not-needed

Index: magics++-4.5.0/apps/metgram/metgram
===================================================================
--- magics++-4.5.0.orig/apps/metgram/metgram
+++ magics++-4.5.0/apps/metgram/metgram
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 use strict;
 use Data::Dumper;
 use IO::Socket;
Index: magics++-4.5.0/tools/magicsCompatibilityChecker
===================================================================
--- magics++-4.5.0.orig/tools/magicsCompatibilityChecker
+++ magics++-4.5.0/tools/magicsCompatibilityChecker
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
 #
 # Copyright 2011 European Centre for Medium-Range Weather Forecasts (ECMWF)
 #