Package: mapsembler2 / 2.2.4+dfsg-3

Metadata

Package Version Patches format
mapsembler2 2.2.4+dfsg-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
use_debian_libs | (download)

mapsembler2_extremities/thirdparty/gatb-core/CMakeLists.txt | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/math/LargeInt.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/math/NativeInt128.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/math/NativeInt16.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/math/NativeInt64.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/math/NativeInt8.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/misc/api/Abundance.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/misc/api/IHistogram.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/storage/impl/CollectionHDF5.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/src/gatb/tools/storage/impl/StorageHDF5.hpp | 2 1 + 1 - 0 !
mapsembler2_extremities/thirdparty/gatb-core/thirdparty/CMakeLists.txt | 42 0 + 42 - 0 !
11 files changed, 10 insertions(+), 52 deletions(-)

 use debian libs instead of embedded one
run_pipeline | (download)

run_mapsembler2_pipeline.sh | 20 10 + 10 - 0 !
1 file changed, 10 insertions(+), 10 deletions(-)

 use tools in path instead of local dirs as upstream
Last-Updated: 2014-08-20
add_hardening | (download)

kissreads/Makefile | 4 4 + 0 - 0 !
kissreads_graph/makefile | 5 4 + 1 - 0 !
mapsembler2_extend/makefile | 7 6 + 1 - 0 !
mapsembler2_extremities/CMakeLists.txt | 1 1 + 0 - 0 !
4 files changed, 15 insertions(+), 2 deletions(-)

 add hardening
skip_mphe | (download)

mapsembler2_extremities/thirdparty/gatb-core/CMakeLists.txt | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 mphe uses sse which is not available on all archs
 Disable in makefile the use of this lib as not mandatory
gcc 5.patch | (download)

mapsembler2_extend/mapsembler_extend.cpp | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix type of prefix_trashable since gcc-5 is picky about it


libgomp.patch | (download)

kissreads/Makefile | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 add missing -lgomp


spelling.patch | (download)

kissreads_graph/KissReadsGraph.cpp | 2 1 + 1 - 0 !
mapsembler2_extend/IterativeExtensions.cpp | 4 2 + 2 - 0 !
2 files changed, 3 insertions(+), 3 deletions(-)

 fix spelling