Package: mina2 / 2.0.19-2

Metadata

Package Version Patches format
mina2 2.0.19-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
03 easymock compatibility.patch | (download)

src/mina-filter-compression/src/test/java/org/apache/mina/filter/compression/CompressionFilterTest.java | 81 32 + 49 - 0 !
1 file changed, 32 insertions(+), 49 deletions(-)

 ensures the compatibility with easymock 3
05 spring dependency.patch | (download)

src/mina-integration-xbean/pom.xml | 6 6 + 0 - 0 !
src/mina-integration-xbean/src/test/java/org/apache/mina/integration/xbean/SpringXBeanTest.java | 1 1 + 0 - 0 !
2 files changed, 7 insertions(+)

 ensures the compatibility with spring 3.x
xbean plugin version.patch | (download)

src/pom.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 xbean-plugin version

This patch should not be necessary. A new rule to override the version of
xbean-plugin has no effect in maven.rules. This is Debian bug #907477.
Ideally libxbean-java should provide a debian version of xbean-plugin. This
package will break again whenever someone packages a new upstream version of
libxbean-java.

Bug-Debian: https://bugs.debian.org/907001