Package: mumble / 1.3.0~git20190125.440b173+dfsg-2

Metadata

Package Version Patches format
mumble 1.3.0~git20190125.440b173+dfsg-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
06 lsb lower dbus dependency.diff | (download)

scripts/murmur.init | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

 remove init script dependency on dbus
 For more information, see #731003
Bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=731003
07 use embedded celt baseline.diff | (download)

main.pro | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 include embedded celt 0.7.1 only, as this is a base requirement
 for Mumble, but avoid shipping any other version to minimize possible
 security risks with CELT due to being dead upstream
Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=682010
12 disable ice by default.diff | (download)

scripts/murmur.ini.system | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable ice by default
25 make logfiles readable by adm.diff | (download)

scripts/murmur.logrotate | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 create logfiles owned by group adm in logrotate snippet
35 add dpkg buildflags.diff | (download)

overlay_gl/overlay_gl.pro | 10 10 + 0 - 0 !
qmake/compiler.pri | 5 5 + 0 - 0 !
2 files changed, 15 insertions(+)

 add dpkg-buildflags hardening flags via qmake
 https://wiki.debian.org/Hardening#Notes_for_packages_using_QMake
 The overlay intentionally disables the  "-z,now" linker flag in
 order to be able to resolve OpenGL symbols at runtime without
 linking against a specific libGL implementation.
44 add speechd header.diff | (download)

src/mumble.pri | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 fix include path for the speechd headers for ubuntu
46 var run to run.diff | (download)

scripts/murmur.ini.system | 2 1 + 1 - 0 !
scripts/murmur.init | 2 1 + 1 - 0 !
scripts/murmur.logrotate | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 patch to replace /var/run path with /run as suggested in the
 Debian Policy Manual section 9.1.1 and close bug #693348
Bug-Debian: http://bugs.debian.org/693348
52 use update rc.d for disable.diff | (download)

scripts/murmur.init | 5 0 + 5 - 0 !
1 file changed, 5 deletions(-)

 remove disable from init script to comply with debian policy
 section ยง9.3.3.1. Daemon enable/disable is now via command
 'update-rc.d mumble-server [enable|disable]' instead.
60 crossbuild.diff | (download)

main.pro | 6 3 + 3 - 0 !
qmake/compiler.pri | 1 1 + 0 - 0 !
qmake/pkgconfig.pri | 4 3 + 1 - 0 !
src/mumble.pri | 2 1 + 1 - 0 !
src/mumble/mumble.pro | 16 8 + 8 - 0 !
src/murmur/murmur.pro | 2 1 + 1 - 0 !
6 files changed, 17 insertions(+), 14 deletions(-)

 remove hard coding of pkg-config to make package cross buildable
65 fix sample path.diff | (download)

src/mumble/AudioWizard.cpp | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix missing audio samples due to location change
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=921268