Package: mysql-connector-java / 5.1.42-1~deb8u1

Metadata

Package Version Patches format
mysql-connector-java 5.1.42-1~deb8u1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 disable testsuite.patch | (download)

build.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 [patch] disable testsuite


0002 java6 compilation compat.patch | (download)

src/com/mysql/fabric/jdbc/FabricMySQLConnectionProxy.java | 32 32 + 0 - 0 !
src/com/mysql/fabric/jdbc/FabricMySQLDriver.java | 4 2 + 2 - 0 !
src/com/mysql/jdbc/CallableStatement.java | 84 84 + 0 - 0 !
src/com/mysql/jdbc/ConnectionImpl.java | 52 52 + 0 - 0 !
src/com/mysql/jdbc/DatabaseMetaData.java | 16 16 + 0 - 0 !
src/com/mysql/jdbc/MultiHostMySQLConnection.java | 52 52 + 0 - 0 !
src/com/mysql/jdbc/NonRegisteringDriver.java | 5 5 + 0 - 0 !
src/com/mysql/jdbc/PreparedStatement.java | 12 12 + 0 - 0 !
src/com/mysql/jdbc/ResultSetImpl.java | 196 196 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/CallableStatementWrapper.java | 136 136 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/ConnectionWrapper.java | 52 52 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/MysqlDataSource.java | 12 12 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/MysqlPooledConnection.java | 11 11 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/PreparedStatementWrapper.java | 72 72 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/StatementWrapper.java | 28 28 + 0 - 0 !
src/com/mysql/jdbc/jdbc2/optional/SuspendableXAConnection.java | 8 8 + 0 - 0 !
16 files changed, 770 insertions(+), 2 deletions(-)

 [patch] java 8 compatibility


0003 disable hibernate fabric.patch | (download)

build.xml | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

 do not compile multitenantconnectionprovider since it requires hibernate 4 which isn't in debian yet
0004 skip jdk check.patch | (download)

build.xml | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable the jdk check
remove JDBC 4 classes.patch | (download)

build.xml | 33 0 + 33 - 0 !
1 file changed, 33 deletions(-)

 remove jdbc 4+ classes

Java 8 is not available in Debian's stable and oldstable distributions.
Do not compile JDBC 4+ classes that require it.

disable JDBC42 invocation.patch | (download)

src/com/mysql/jdbc/Util.java | 9 1 + 8 - 0 !
1 file changed, 1 insertion(+), 8 deletions(-)

 disable jdbc42 invocation

Debian-Bug: https://bugs.debian.org/828836