Package: newsbeuter / 2.9-8

22-use-pkg-config-to-search-for-ncursesw.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
From: Jan Pobrislo <ccx@webprojekty.cz>
Subject: Use pkg-config to search for ncursesw.
Origin: upstream, https://github.com/akrennmair/newsbeuter/commit/02f08698f74bb5bba6f036292b1d26fd22255c7f
Bug: https://github.com/akrennmair/newsbeuter/issues/198

--- a/config.sh
+++ b/config.sh
@@ -110,6 +110,7 @@
 if [ `uname -s` = "Darwin" ]; then
 	check_custom "ncurses5.4" "ncurses5.4-config" || fail "ncurses5.4"
 elif [ `uname -s` != "OpenBSD" ]; then
+	check_pkg "ncursesw" || \
 	check_custom "ncursesw5" "ncursesw5-config" ||  fail "ncursesw"
 fi
 check_ssl_implementation