Package: nipype / 1.1.8-1

Metadata

Package Version Patches format
nipype 1.1.8-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
deb_skip_doctest_pybids | (download)

nipype/interfaces/io.py | 14 7 + 7 - 0 !
1 file changed, 7 insertions(+), 7 deletions(-)

---
deb_simplify_requires | (download)

nipype/info.py | 8 3 + 5 - 0 !
1 file changed, 3 insertions(+), 5 deletions(-)

 bf(temp): remove python_version== from requires spec

    Is not understood by older dh_python e.g. on debian stretch
    leading to a bizzare dependency.  It would need to be removed for
    python3 support

deb_no_explicit_pydot | (download)

nipype/info.py | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

---
deb_imgmath_optional | (download)

doc/conf.py | 6 5 + 1 - 0 !
1 file changed, 5 insertions(+), 1 deletion(-)

---
deb_down_future | (download)

nipype/info.py | 2 1 + 1 - 0 !
requirements.txt | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 downgrade requirement for future

I believe that 0.16.0 was demanded for compatibility with python 3.6.  All
tests seems to function correctly with 0.15.2

deb_no_strict_versions | (download)

nipype/info.py | 5 3 + 2 - 0 !
1 file changed, 3 insertions(+), 2 deletions(-)

---
deb_no_neurdflib | (download)

nipype/info.py | 3 2 + 1 - 0 !
requirements.txt | 2 1 + 1 - 0 !
2 files changed, 3 insertions(+), 2 deletions(-)

---
deb_robust_apidocgen | (download)

tools/interfacedocgen.py | 6 5 + 1 - 0 !
1 file changed, 5 insertions(+), 1 deletion(-)

---
deb_disable_google_online_snippets | (download)

doc/_templates/gse.html | 3 3 + 0 - 0 !
doc/_templates/layout.html | 19 6 + 13 - 0 !
doc/_templates/navbar.html | 1 0 + 1 - 0 !
doc/_templates/sidebar_versions.html | 7 0 + 7 - 0 !
doc/searchresults.rst | 3 3 + 0 - 0 !
5 files changed, 12 insertions(+), 21 deletions(-)

---
deb_git_hash | (download)

nipype/COMMIT_INFO.txt | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 manually specifying the hash for the release
 Otherwise leads to parser failures etc