Package: nipype / 1.6.0-2

Metadata

Package Version Patches format
nipype 1.6.0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
deb_skip_doctest_pybids | (download)

nipype/interfaces/io.py | 14 7 + 7 - 0 !
1 file changed, 7 insertions(+), 7 deletions(-)

 skip doctest pybids


deb_simplify_requires | (download)

nipype/info.py | 3 1 + 2 - 0 !
1 file changed, 1 insertion(+), 2 deletions(-)

 bf(temp): remove python_version== from requires spec

    Is not understood by older dh_python e.g. on debian stretch
    leading to a bizarre dependency.  It would need to be removed for
    python3 support

deb_no_explicit_pydot | (download)

nipype/info.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 skip pydot version test


deb_disable_google_online_snippets | (download)

doc/_templates/gse.html | 3 3 + 0 - 0 !
doc/_templates/layout.html | 19 6 + 13 - 0 !
doc/_templates/navbar.html | 1 0 + 1 - 0 !
doc/_templates/sidebar_versions.html | 7 0 + 7 - 0 !
doc/searchresults.rst | 3 3 + 0 - 0 !
5 files changed, 12 insertions(+), 21 deletions(-)

 disable google online snippets


python3.patch | (download)

Makefile | 2 1 + 1 - 0 !
nipype/__init__.py | 2 1 + 1 - 0 !
tools/gitwash_dumper.py | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 force usage of python3


sphinx.patch | (download)

doc/conf.py | 33 19 + 14 - 0 !
doc/requirements.txt | 2 0 + 2 - 0 !
nipype/sphinxext/apidoc/__init__.py | 2 1 + 1 - 0 !
nipype/sphinxext/apidoc/docstring.py | 4 2 + 2 - 0 !
4 files changed, 22 insertions(+), 19 deletions(-)

 get sphinx doc somehow building