Package: node-babel7 / 7.12.12+~cs150.141.84-6

Metadata

Package Version Patches format
node-babel7 7.12.12+~cs150.141.84-6 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
use system gulp.patch | (download)

Makefile | 38 31 + 7 - 0 !
1 file changed, 31 insertions(+), 7 deletions(-)

 use system gulp
load plugins from system libraries.diff | (download)

packages/babel-core/src/config/files/plugins.js | 7 7 + 0 - 0 !
1 file changed, 7 insertions(+)

 add debian paths to find babel plugins
skip prettier.patch | (download)

scripts/utils/formatCode.js | 8 1 + 7 - 0 !
1 file changed, 1 insertion(+), 7 deletions(-)

 prettier is not packaged, so we will skip it
fix babel plugin dynamic import node.diff | (download)

Makefile | 2 1 + 1 - 0 !
babel-plugin-dynamic-import-node/.babelrc | 8 2 + 6 - 0 !
babel-plugin-dynamic-import-node/package.json | 8 2 + 6 - 0 !
3 files changed, 5 insertions(+), 13 deletions(-)

 fix babel-plugin-dynamic-import-node build
fix large numbers.diff | (download)

packages/babel-core/src/transformation/normalize-file.js | 2 1 + 1 - 0 !
packages/babel-generator/src/index.js | 2 1 + 1 - 0 !
packages/babel-traverse/src/context.js | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 fix large numbers
fix pirates build.diff | (download)

pirates/package.json | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 add missing build dependency to yarn in npm build profile
switch to yarnpkg.patch | (download)

babel-plugin-dynamic-import-node/package.json | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
remove useless dependency.patch | (download)

packages/babel-node/package.json | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 node-environment-flags isn't required anywhere
 and it's just a polyfill of process.allowedNodeEnvironmentFlags
ignore one missing ts definition.patch | (download)

packages/babel-helper-validator-identifier/src/identifier.ts | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 ignore charcode ts definitions
update rollup and babel paths.patch | (download)

Gulpfile.js | 6 6 + 0 - 0 !
babel.config.js | 4 4 + 0 - 0 !
2 files changed, 10 insertions(+)

 update babel and rollup paths to use debian packages files