Package: node-databank / 0.19.1-1

remove-set-immediate Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
Description: Remove calls to require("set-immediate")
 The library "set-immediate" is deprecated in favour of "setimmediate".
 However, Debian only ships nodejs >= 0.10, so both are unnecessary.  An
 alternative would be to package node-setimmediate, perhaps in a bundle.
Author: Tim Retout <diocles@debian.org>
Bug: https://github.com/e14n/databank/issues/39

Index: node-databank/lib/drivers/memory.js
===================================================================
--- node-databank.orig/lib/drivers/memory.js
+++ node-databank/lib/drivers/memory.js
@@ -18,7 +18,6 @@
 
 var Step = require('step'),
     databank = require('../databank'),
-    si = require('set-immediate'),
     Databank = databank.Databank,
     DatabankError = databank.DatabankError,
     AlreadyExistsError = databank.AlreadyExistsError,
Index: node-databank/lib/test/array.js
===================================================================
--- node-databank.orig/lib/test/array.js
+++ node-databank/lib/test/array.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Databank = databank.Databank;
 
Index: node-databank/lib/test/basic-crud.js
===================================================================
--- node-databank.orig/lib/test/basic-crud.js
+++ node-databank/lib/test/basic-crud.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Databank = databank.Databank;
 
Index: node-databank/lib/test/float.js
===================================================================
--- node-databank.orig/lib/test/float.js
+++ node-databank/lib/test/float.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Databank = databank.Databank;
 
Index: node-databank/lib/test/integer.js
===================================================================
--- node-databank.orig/lib/test/integer.js
+++ node-databank/lib/test/integer.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Databank = databank.Databank;
 
Index: node-databank/lib/test/object-del-hook.js
===================================================================
--- node-databank.orig/lib/test/object-del-hook.js
+++ node-databank/lib/test/object-del-hook.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Databank = databank.Databank,
     DatabankObject = require('../databankobject').DatabankObject;
Index: node-databank/lib/test/object-delete-and-search.js
===================================================================
--- node-databank.orig/lib/test/object-delete-and-search.js
+++ node-databank/lib/test/object-delete-and-search.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Step = require('step'),
     Databank = databank.Databank,
Index: node-databank/lib/test/object.js
===================================================================
--- node-databank.orig/lib/test/object.js
+++ node-databank/lib/test/object.js
@@ -18,7 +18,6 @@
 
 var assert = require('assert'),
     vows = require('vows'),
-    si = require('set-immediate'),
     databank = require('../databank'),
     Step = require('step'),
     Databank = databank.Databank,
Index: node-databank/lib/drivers/partitioning.js
===================================================================
--- node-databank.orig/lib/drivers/partitioning.js
+++ node-databank/lib/drivers/partitioning.js
@@ -16,8 +16,6 @@
 // See the License for the specific language governing permissions and
 // limitations under the License.
 
-require('set-immediate');
-
 var databank = require('../databank'),
     Step = require('step'),
     EventEmitter = require('events').EventEmitter,