Package: node-gyp / 3.8.0-6

Metadata

Package Version Patches format
node-gyp 3.8.0-6 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
2002_set_default_nodedir.patch | (download)

lib/configure.js | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

 set nodejs-dev headers path for default --nodedir
 Expected behavior: node-gyp does not install remote headers when
 configuring a module targeted at current nodejs version.
2003_fPIC_ia32.patch | (download)

addon.gypi | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 let -fpic be the default on all archs
 http://lintian.debian.org/tags/shlib-with-non-pic-code.html
kfreebsd.patch | (download)

lib/build.js | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 kfreebsd is not like *bsd and have make
link_libnode.patch | (download)

addon.gypi | 5 5 + 0 - 0 !
1 file changed, 5 insertions(+)

 link to node shared lib on debian
tar3 compat.patch | (download)

lib/install.js | 38 16 + 22 - 0 !
package.json | 5 2 + 3 - 0 !
2 files changed, 18 insertions(+), 25 deletions(-)

 [patch] upgrade to tar v3

Tar version 3 performs better and is more well tested than its
predecessor.  npm will be using this in the near future, so there is no
benefit in shipping a node-gyp that uses the slower and less reliable
fstream-based tar.

This drops support for node 0.x, and thus should be considered a
breaking semver-major change.

PR-URL: https://github.com/nodejs/node-gyp/pull/1212