Package: node-rollup / 2.38.4-1

Metadata

Package Version Patches format
node-rollup 2.38.4-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
disable help.patch | (download)

cli/cli.ts | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 disable help
 Ugly hack: rollup is required for importing .md files. This removes circular
 build dependency. This should be fixed properly when we have latest version of
 rollup in the archive and a proper staged build is used.
use pluginutils cjs.patch | (download)

src/watch/watch.ts | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use pluginutils cjs
 Use cjs format from rollup-pluginutils as we don't build or ship these
 individual js files in src (we only have indiviaul ts files and cjs bundle).
 .
 Bug, upstream: https://github.com/rollup/rollup/pull/3165
help md format fixes.patch | (download)

cli/help.md | 37 27 + 10 - 0 !
1 file changed, 27 insertions(+), 10 deletions(-)

 help md format fixes
 These changes are useful to make a nicer man page
hardcode version.patch | (download)

src/rollup/rollup.ts | 2 1 + 1 - 0 !
src/utils/PluginContext.ts | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 hardcode version
 Ugly hack: rollup is required for importing package.json. This removes circular
 build dependency. This should be fixed properly when we have latest version of
 rollup in the archive and a proper staged build is used.
workaround outdated libs.diff | (download)

cli/cli.ts | 2 1 + 1 - 0 !
cli/run/build.ts | 2 1 + 1 - 0 !
cli/run/getConfigPath.ts | 2 1 + 1 - 0 !
cli/run/timings.ts | 2 1 + 1 - 0 !
cli/run/watch-cli.ts | 8 4 + 4 - 0 !
rollup.config.js | 3 1 + 2 - 0 !
src/utils/options/normalizeInputOptions.ts | 4 2 + 2 - 0 !
src/watch/fileWatcher.ts | 3 2 + 1 - 0 !
8 files changed, 13 insertions(+), 13 deletions(-)

 workaround for debian packages that don't export correctly
disable conditional fsevents import.diff | (download)

rollup.config.js | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 conditional-fsevents-import is for macos
search module in debian dirs.diff | (download)

rollup.config.js | 6 5 + 1 - 0 !
1 file changed, 5 insertions(+), 1 deletion(-)

 search module also in debian directories
dont build browser module.diff | (download)

rollup.config.js | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 don't build browser module
dont fail on warn.diff | (download)

rollup.config.js | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 workaround "'this' keyword is equivalent to 'undefined'" failure
ignore failure on dynamic import.diff | (download)

build-plugins/esm-dynamic-import.js | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 ignore failure on dynamic import
fix shebang.diff | (download)

build-plugins/add-cli-entry.js | 2 1 + 1 - 0 !
scripts/post-comment.js | 2 1 + 1 - 0 !
scripts/update-snapshots.js | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 fix shebang
dont embed acorn.diff | (download)

src/Graph.ts | 2 1 + 1 - 0 !
src/Module.ts | 2 1 + 1 - 0 !
src/ModuleLoader.ts | 2 1 + 1 - 0 !
src/utils/pureComments.ts | 4 2 + 2 - 0 !
4 files changed, 5 insertions(+), 5 deletions(-)

 don't embed acorn
fix commonjs path.diff | (download)

rollup.config.js | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 commonjs plugin has to be applied outside node_modules