Package: notion / 4.0.2+dfsg-5

cross.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
--- notion-4.0.2+dfsg.orig/build/lua-detect.mk
+++ notion-4.0.2+dfsg/build/lua-detect.mk
@@ -28,7 +28,7 @@
 # and there won't be any guarantees it looks the same as elsewhere.
 # We try the package names lua$(ver), lua-$(ver) for all candidate versions in
 # descending order and last but not least "lua" here.
-PKG_CONFIG_ALL_PACKAGES:= $(shell pkg-config --list-all | cut -f1 -d' ')
+PKG_CONFIG_ALL_PACKAGES:= $(shell $(PKG_CONFIG) --list-all | cut -f1 -d' ')
 
 # these are in order of preference
 LUA_CANDIDATES:=		$(or $(LUA_VERSION),5.3 5.2 5.1)
@@ -52,12 +52,12 @@
 	variables manually: LUA LUAC LUA_VERSION LUA_LIBS LUA_INCLUDES)
 endif
 
-PKG_CONFIG_LUA_VERSION:=	$(shell pkg-config --modversion $(PKG_CONFIG_LUA) | cut -d. -f-2)
+PKG_CONFIG_LUA_VERSION:=	$(shell $(PKG_CONFIG) --modversion $(PKG_CONFIG_LUA) | cut -d. -f-2)
 
 $(info >> pkg-config found Lua $(PKG_CONFIG_LUA_VERSION) (available: $(PKG_CONFIG_LUA_PACKAGES:=)).)
 
-LUA_LIBS=	$(shell pkg-config --libs $(PKG_CONFIG_LUA))
-LUA_INCLUDES=	$(shell pkg-config --cflags $(PKG_CONFIG_LUA))
+LUA_LIBS=	$(shell $(PKG_CONFIG) --libs $(PKG_CONFIG_LUA))
+LUA_INCLUDES=	$(shell $(PKG_CONFIG) --cflags $(PKG_CONFIG_LUA))
 LUA_VERSION?=	$(PKG_CONFIG_LUA_VERSION)
 
 LUA=		$(firstword $(foreach bin,$(LUA_BIN_CANDIDATES),$(call pathsearch,$(bin))))
--- notion-4.0.2+dfsg.orig/libextl/system-autodetect.mk
+++ notion-4.0.2+dfsg/libextl/system-autodetect.mk
@@ -2,6 +2,7 @@
 ## System settings
 ##
 
+PKG_CONFIG ?= pkg-config
 
 ##
 ## Installation paths
@@ -65,24 +66,24 @@
 
 ifndef LUA_MANUAL
 
-ifeq (5.2,$(findstring 5.2,$(shell pkg-config --exists lua5.2 && pkg-config --modversion lua5.2)))
+ifeq (5.2,$(findstring 5.2,$(shell $(PKG_CONFIG) --exists lua5.2 && $(PKG_CONFIG) --modversion lua5.2)))
 
-LUA_LIBS=`pkg-config --libs lua5.2`
-LUA_INCLUDES=`pkg-config --cflags lua5.2`
+LUA_LIBS=`$(PKG_CONFIG) --libs lua5.2`
+LUA_INCLUDES=`$(PKG_CONFIG) --cflags lua5.2`
 LUA=`which lua5.2`
 LUAC=`which luac5.2`
 
-else ifeq (5.1,$(findstring 5.1,$(shell pkg-config --exists lua5.1 && pkg-config --modversion lua5.1)))
+else ifeq (5.1,$(findstring 5.1,$(shell $(PKG_CONFIG) --exists lua5.1 && $(PKG_CONFIG) --modversion lua5.1)))
 
-LUA_LIBS=`pkg-config --libs lua5.1`
-LUA_INCLUDES=`pkg-config --cflags lua5.1`
+LUA_LIBS=`$(PKG_CONFIG) --libs lua5.1`
+LUA_INCLUDES=`$(PKG_CONFIG) --cflags lua5.1`
 LUA=`which lua5.1`
 LUAC=`which luac5.1`
 
-else ifeq (5.1,$(findstring 5.1,$(shell pkg-config --exists lua && pkg-config --modversion lua)))
+else ifeq (5.1,$(findstring 5.1,$(shell $(PKG_CONFIG) --exists lua && $(PKG_CONFIG) --modversion lua)))
 
-LUA_LIBS=`pkg-config --libs lua`
-LUA_INCLUDES=`pkg-config --cflags lua`
+LUA_LIBS=`$(PKG_CONFIG) --libs lua`
+LUA_INCLUDES=`$(PKG_CONFIG) --cflags lua`
 LUA=`which lua`
 LUAC=`which luac`
 
--- notion-4.0.2+dfsg.orig/system-autodetect.mk
+++ notion-4.0.2+dfsg/system-autodetect.mk
@@ -102,12 +102,12 @@
 ##
 
 ifeq ($(USE_XFT),)
-USE_XFT:=$(shell (pkg-config --exists xft && echo 1))
+USE_XFT:=$(shell ($(PKG_CONFIG) --exists xft && echo 1))
 endif
 
 ifeq ($(USE_XFT),1)
-    X11_INCLUDES += $(shell pkg-config xft --cflags)
-    X11_LIBS += $(shell pkg-config xft --libs)
+    X11_INCLUDES += $(shell $(PKG_CONFIG) xft --cflags)
+    X11_LIBS += $(shell $(PKG_CONFIG) xft --libs)
     DEFINES += -DHAVE_X11_XFT
     DEFINES += -DHAVE_X11_BMF
 else
@@ -122,8 +122,8 @@
     # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901650
     READLINE_INCLUDES_FALLBACK := -D_XOPEN_SOURCE=600 -I/usr/include/readline
     READLINE_LIBS_FALLBACK := -lreadline
-    READLINE_INCLUDES ?= $(shell pkg-config readline --cflags || echo $(READLINE_INCLUDES_FALLBACK))
-    READLINE_LIBS ?= $(shell pkg-config readline --libs || echo $(READLINE_LIBS_FALLBACK))
+    READLINE_INCLUDES ?= $(shell $(PKG_CONFIG) readline --cflags || echo $(READLINE_INCLUDES_FALLBACK))
+    READLINE_LIBS ?= $(shell $(PKG_CONFIG) readline --libs || echo $(READLINE_LIBS_FALLBACK))
 endif
 
 ##