Package: octave / 4.4.1-6

install_libraries_publically Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
Description: Install the Octave libraries publically in /usr/lib/
 Thanks to John Eaton for helping with this.
 .
 The patch is currently not needed upstream, but forwarding it might make sense
 in the future.
Forwarded: not-needed
Author: Thomas Weber <tweber@debian.org>
Reviewed-by: Rafael Laboissière <rafael@debian.org>
Last-Update: 2016-11-20
--- a/Makefile.am
+++ b/Makefile.am
@@ -178,6 +178,7 @@ OCTAVE_CROSS_TOOLS =
 OCTAVE_INTERPRETER_TARGETS =
 
 octlib_LTLIBRARIES =
+lib_LTLIBRARIES =
 noinst_LTLIBRARIES =
 
 octinclude_HEADERS =
--- a/liboctave/module.mk
+++ b/liboctave/module.mk
@@ -21,7 +21,7 @@
 
 %canon_reldir%_%canon_reldir%_la_CXXFLAGS = $(AM_CXXFLAGS) $(WARN_CXXFLAGS)
 
-octlib_LTLIBRARIES += %reldir%/liboctave.la
+lib_LTLIBRARIES += %reldir%/liboctave.la
 
 BUILT_INCS = \
   $(BUILT_LIBOCTAVE_OPERATORS_INC) \
--- a/libinterp/module.mk
+++ b/libinterp/module.mk
@@ -26,7 +26,7 @@
 
 %canon_reldir%_liboctinterp_la_CXXFLAGS = $(AM_CXXFLAGS) $(WARN_CXXFLAGS)
 
-octlib_LTLIBRARIES += %reldir%/liboctinterp.la
+lib_LTLIBRARIES += %reldir%/liboctinterp.la
 
 BUILT_SOURCES += \
   %reldir%/builtin-defun-decls.h \