Package: ohai / 6.14.0-2

Metadata

Package Version Patches format
ohai 6.14.0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
Missing require rubygems.patch | (download)

spec/ohai/plugins/ruby_spec.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 add missing `require 'rubygems'`
 Without this, the tests do not pass under Ruby 1.8
Obtain Ruby plugin test data from system ruby.patch | (download)

spec/ohai/plugins/ruby_spec.rb | 40 26 + 14 - 0 !
1 file changed, 26 insertions(+), 14 deletions(-)

 obtain ruby plugin test data from system ruby
 This fixes the tests for the case where `ruby` is not the same Ruby
 interpreter as the one you are running the tests against. For example, the
 `ruby` in yout $PATH might be Ruby 1.8, but you are running the tests under
 Ruby 1.9 (or vice-versa).