Package: open-vm-tools / 2:10.1.5-5055683-4+deb9u1

Metadata

Package Version Patches format
open-vm-tools 2:10.1.5-5055683-4+deb9u1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
debian/0001 kvers.patch | (download)

open-vm-tools/modules/linux/vmblock/Makefile | 2 1 + 1 - 0 !
open-vm-tools/modules/linux/vmci/Makefile | 2 1 + 1 - 0 !
open-vm-tools/modules/linux/vmsync/Makefile | 2 1 + 1 - 0 !
open-vm-tools/modules/linux/vmxnet/Makefile | 2 1 + 1 - 0 !
open-vm-tools/modules/linux/vsock/Makefile | 2 1 + 1 - 0 !
5 files changed, 5 insertions(+), 5 deletions(-)

 replacing uname call with kvers, overwriting seemed not to work.


debian/pam use common auth account | (download)

open-vm-tools/scripts/linux/pam.d/vmtoolsd | 14 7 + 7 - 0 !
1 file changed, 7 insertions(+), 7 deletions(-)

---
debian/max_nic_count | (download)

open-vm-tools/lib/guestRpc/nicinfo.x | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
from_arch/0001 Fix vmxnet module on kernels 3.16.patch | (download)

open-vm-tools/modules/linux/shared/compat_netdevice.h | 4 4 + 0 - 0 !
open-vm-tools/modules/linux/vmxnet/vmxnet.c | 13 8 + 5 - 0 !
2 files changed, 12 insertions(+), 5 deletions(-)

 [patch 1/3] fix vmxnet module on kernels >= 3.16

* Add compat check for ethtool_ops in net_device struct.
* SET_ETHTOOL_OPS is no longer defined, but can be manually.

debian/enable_vmhgfs fuse_by_default | (download)

open-vm-tools/vmhgfs-fuse/config.c | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

---
debian/vmxnet_fix_kernel_4.7.patch | (download)

open-vm-tools/modules/linux/vmxnet/vmxnet.c | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

---
debian/cve 2015 5191.patch | (download)

open-vm-tools/libDeployPkg/linuxDeployment.c | 232 114 + 118 - 0 !
1 file changed, 114 insertions(+), 118 deletions(-)

---