Package: pdf2htmlex / 0.12+ds-1

Metadata

Package Version Patches format
pdf2htmlex 0.12+ds-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
no install LICENSE | (download)

CMakeLists.txt | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 do not install additional license file
use system yui compressor and closure compiler | (download)

share/build_css.sh | 14 3 + 11 - 0 !
share/build_js.sh | 22 8 + 14 - 0 !
2 files changed, 11 insertions(+), 25 deletions(-)

 use system's yui-compressor and closure-compiler
use system pdfjs | (download)

CMakeLists.txt | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 use system pdf.js version of compatibility.js
use rsvg | (download)

logo/update_png.sh | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 use rsvg-convert instead of imagemagick to reduce dependencies
use system compatibilityjs non min | (download)

share/manifest | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 the libjs-pdf package does not provide compatibility.min.js so we use the full version (#754533)
do not ship unused js | (download)

CMakeLists.txt | 3 0 + 3 - 0 !
1 file changed, 3 deletions(-)

 do not ship the javascript that is never used
control test executable name | (download)

test/test_naming.py | 8 6 + 2 - 0 !
1 file changed, 6 insertions(+), 2 deletions(-)

 allow controlling which pdf2htmlex executable is chosen for testing
allow old libfontforge | (download)

CMakeLists.txt | 64 60 + 4 - 0 !
src/util/ffw.c | 2 1 + 1 - 0 !
2 files changed, 61 insertions(+), 5 deletions(-)

 reverting commit: remove support for old versions of fontforge
fix spelling | (download)

pdf2htmlEX.1.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fixing a number of spelling mistakes throughout the codebase