Package: pdfmod / 0.8.3-1

Metadata

Package Version Patches format
pdfmod 0.8.3-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Autodetect external poppler sharp.patch | (download)

configure.ac | 24 23 + 1 - 0 !
lib/poppler-sharp/Makefile.am | 5 4 + 1 - 0 !
2 files changed, 27 insertions(+), 2 deletions(-)

 [patch 1/3] autodetect external poppler-sharp

Now that poppler-sharp has had a tarball release, detect the system's
poppler-sharp installation if present, and use it accordingly. Also
provide an option --(enable|disable)-external-poppler-sharp which can
override the automagic.

Signed-off-by: Gabriel Burt <gabriel.burt@gmail.com>

0002 Fix PDFMod s compilation to choose correct Poppler.patch | (download)

src/Makefile.am | 28 7 + 21 - 0 !
1 file changed, 7 insertions(+), 21 deletions(-)

 [patch 2/3] fix pdfmod's compilation to choose correct poppler#

Signed-off-by: Gabriel Burt <gabriel.burt@gmail.com>

0003 Make POPPLER_SHARP_DLL_CONFIG conditional.patch | (download)

src/Makefile.am | 6 3 + 3 - 0 !
1 file changed, 3 insertions(+), 3 deletions(-)

 [patch 3/3] make poppler_sharp_dll_config conditional

Only add POPPLER_SHARP_DLL_CONFIG to PROGRAMFILES if USE_BUNDLED_POPPLER
is true, as it should be copied from the external installation
otherwise.

Signed-off-by: Gabriel Burt <gabriel.burt@gmail.com>