Package: perl4caml / 0.9.5-4

Metadata

Package Version Patches format
perl4caml 0.9.5-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Fix Makefile to detect ocamlopt.patch | (download)

Makefile | 29 26 + 3 - 0 !
1 file changed, 26 insertions(+), 3 deletions(-)

 [patch] fix makefile to detect ocamlopt

Signed-off-by: Mike Furr <mfurr@debian.org>
Signed-off-by: Stephane Glondu <steph@glondu.net>

0002 Disable libnet google perl wrappers.patch | (download)

Makefile | 16 7 + 9 - 0 !
1 file changed, 7 insertions(+), 9 deletions(-)

 [patch] disable libnet-google-perl wrappers

As a consequence of #550329, see also #409163.

Signed-off-by: Stephane Glondu <steph@glondu.net>

0003 Fix for Perl 5.12 SVt_RV missing.patch | (download)

perl_c.c | 7 7 + 0 - 0 !
1 file changed, 7 insertions(+)

 [patch] fix for perl 5.12: svt_rv missing.

Also reported as the following Debian bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578800

Comment from the author of this patch:
"It seems simplest to pretend that SVt_RV still exists on the caml
side; attached patch will do just that."

Commit taken from upstream Git repository.

Signed-off-by: Stephane Glondu <steph@glondu.net>

debian changes 0.9.5 4 | (download)

.depend | 9 5 + 4 - 0 !
1 file changed, 5 insertions(+), 4 deletions(-)

 upstream changes introduced in version 0.9.5-4
 This patch has been created by dpkg-source during the package build.
 Here's the last changelog entry, hopefully it gives details on why
 those changes were made:
 .
 perl4caml (0.9.5-4) unstable; urgency=low
 .
   * Add 0003-Fix-for-Perl-5.12-SVt_RV-missing.patch (Closes: #578800)
   * Switch source package format to 3.0 (quilt)
   * debian/control:
     - libperl4caml-ocaml-dev: add ocaml-findlib to Recommends
     - bump Standards-Version to 3.8.4 (no changes)
 .
 The person named in the Author field signed this changelog entry.