Package: php-proxy-manager / 2.2.2-1

Metadata

Package Version Patches format
php-proxy-manager 2.2.2-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Point to homemade autoload.php in docs and examples.patch | (download)

docs/access-interceptor-scope-localizer.md | 2 1 + 1 - 0 !
docs/access-interceptor-value-holder.md | 2 1 + 1 - 0 !
docs/lazy-loading-ghost-object.md | 6 3 + 3 - 0 !
docs/lazy-loading-value-holder.md | 2 1 + 1 - 0 !
4 files changed, 6 insertions(+), 6 deletions(-)

 point to homemade autoload.php in docs and examples

0002 Mimic Version getVersion behaviour.patch | (download)

src/ProxyManager/Version.php | 4 1 + 3 - 0 !
1 file changed, 1 insertion(+), 3 deletions(-)

 mimic `version::getversion()` behaviour

Don't rely on Composer or new dependencies to provide the current
version.

0003 Drop versions not understood by dh_phpcomposer.patch | (download)

composer.json | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

 drop versions not understood by dh_phpcomposer

Bug-Debian: https://bugs.debian.org/763052

0004 Workaround the lack of PackageVersions.patch | (download)

src/ProxyManager/Generator/Util/IdentifierSuffixer.php | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 workaround the lack of packageversions