Package: phpldapadmin / 1.2.2-6.3

Metadata

Package Version Patches format
phpldapadmin 1.2.2-6.3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
upstream XSS.patch | (download)

lib/QueryRender.php | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

---
upstream XSS 2.patch | (download)

htdocs/add_value_form.php | 2 1 + 1 - 0 !
htdocs/export.php | 4 2 + 2 - 0 !
lib/export_functions.php | 16 8 + 8 - 0 !
3 files changed, 11 insertions(+), 11 deletions(-)

---
php 5.5 compat.patch | (download)

config/config.php.example | 4 2 + 2 - 0 !
lib/PageRender.php | 6 3 + 3 - 0 !
lib/TemplateRender.php | 2 1 + 1 - 0 !
lib/ds_ldap.php | 17 14 + 3 - 0 !
lib/ds_ldap_pla.php | 2 1 + 1 - 0 !
lib/functions.php | 23 17 + 6 - 0 !
6 files changed, 38 insertions(+), 16 deletions(-)

 [patch] fixed two issues to get phpldapadmin to work under php 5.5.x
 1) password_hash is an actual function, so renamed instances to
 password_hash_custom (HT:
 https://sourceforge.net/mailarchive/message.php?msg_id=31302386) 2) Fixed the
 preg_replace to preg_replace_callback to use the /e/ functionality in the
 officially endorsed fashion


php 7.2 compat.patch | (download)

htdocs/index.php | 5 5 + 0 - 0 !
lib/functions.php | 27 25 + 2 - 0 !
2 files changed, 30 insertions(+), 2 deletions(-)

---
php 7.3 compat.patch | (download)

lib/QueryRender.php | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 [patch] fix for php 7.3 - deprecated continue in switch


CVE 2017 11107.patch | (download)

htdocs/entry_chooser.php | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

---