Package: pkg-info-el / 0.6-4

0002-disable-tests-that-need-network.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
From: Sean Whitton <spwhitton@spwhitton.name>
Date: Sun, 17 Jan 2016 09:50:05 -0700
Subject: disable-tests-that-need-network

---
 test/pkg-info-test.el | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)

diff --git a/test/pkg-info-test.el b/test/pkg-info-test.el
index 49f6f76..9731e83 100644
--- a/test/pkg-info-test.el
+++ b/test/pkg-info-test.el
@@ -163,27 +163,27 @@
 (ert-deftest pkg-info-format-version/prerelease-version ()
   (should (equal (pkg-info-format-version '(2 1 -3)) "2.1alpha")))
 
-(ert-deftest pkg-info-get-melpa-recipe/has-a-proper-recipe ()
-  (should (equal (pkg-info-get-melpa-recipe 'pkg-info)
-                 '((fetcher . "github") (repo . "lunaryorn/pkg-info.el")))))
+;; (ert-deftest pkg-info-get-melpa-recipe/has-a-proper-recipe ()
+;;   (should (equal (pkg-info-get-melpa-recipe 'pkg-info)
+;;                  '((fetcher . "github") (repo . "lunaryorn/pkg-info.el")))))
 
-(ert-deftest pkg-info-get-melpa-recipe/package-does-not-exist ()
-  (should-not (pkg-info-get-melpa-recipe 'foobarblubb)))
+;; (ert-deftest pkg-info-get-melpa-recipe/package-does-not-exist ()
+;;   (should-not (pkg-info-get-melpa-recipe 'foobarblubb)))
 
-(ert-deftest pkg-info-get-melpa-fetcher/has-a-fetcher ()
-  (should (equal (pkg-info-get-melpa-fetcher 'pkg-info) "github")))
+;; (ert-deftest pkg-info-get-melpa-fetcher/has-a-fetcher ()
+;;   (should (equal (pkg-info-get-melpa-fetcher 'pkg-info) "github")))
 
-(ert-deftest pkg-info-get-melpa-fetcher/package-does-not-exist ()
-  (should-not (pkg-info-get-melpa-fetcher 'foobarblubb)))
+;; (ert-deftest pkg-info-get-melpa-fetcher/package-does-not-exist ()
+;;   (should-not (pkg-info-get-melpa-fetcher 'foobarblubb)))
 
-(ert-deftest pkg-info-wiki-package-p/a-wiki-package ()
-  (should (pkg-info-wiki-package-p 'dired+)))
+;; (ert-deftest pkg-info-wiki-package-p/a-wiki-package ()
+;;   (should (pkg-info-wiki-package-p 'dired+)))
 
-(ert-deftest pkg-info-wiki-package-p/not-a-wiki-package ()
-  (should-not (pkg-info-wiki-package-p 'pkg-info)))
+;; (ert-deftest pkg-info-wiki-package-p/not-a-wiki-package ()
+;;   (should-not (pkg-info-wiki-package-p 'pkg-info)))
 
-(ert-deftest pkg-info-wiki-package-p/package-does-not-exist ()
-  (should-not (pkg-info-wiki-package-p 'foobarblubb)))
+;; (ert-deftest pkg-info-wiki-package-p/package-does-not-exist ()
+;;   (should-not (pkg-info-wiki-package-p 'foobarblubb)))
 
 ;; Variables:
 ;; coding: utf-8