Package: planner / 0.14.6-4

Metadata

Package Version Patches format
planner 0.14.6-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
704171 fix print preview crash.patch | (download)

src/planner-print-job.c | 14 1 + 13 - 0 !
1 file changed, 1 insertion(+), 13 deletions(-)

 fix crash on print preview of empty document


desktop validate.patch | (download)

data/planner.desktop.in.in | 12 8 + 4 - 0 !
1 file changed, 8 insertions(+), 4 deletions(-)

 fix .desktop file validation
 Fix problems revealed by "desktop-file-validate".


dependant_typo.diff | (download)

po/eo.po | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 this patch fixes a typo in planner
 (perhaps need to be forwarded again, this is the only typo left since
  last release)


plugins_directory.diff | (download)

libplanner/Makefile.am | 10 5 + 5 - 0 !
src/Makefile.am | 2 1 + 1 - 0 !
2 files changed, 6 insertions(+), 6 deletions(-)

 the configure's --libdir parameter is used to comply with
 Debian Policy 10.2 which states that not public libraries should be
 installed in subdirectories of /usr/lib. This patch was added in
 order to keep the *-modules and plugins directories in the right
 place.
command_line_args.diff | (download)

src/planner-main.c | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 planner is unable to read files from command line.
 This patch solves the issue.
fix as needed build.patch | (download)

src/Makefile.am | 2 1 + 1 - 0 !
tests/Makefile.am | 14 7 + 7 - 0 !
2 files changed, 8 insertions(+), 8 deletions(-)

 fix build with "ld --as-needed", without required "-lm".
 libraries must be behind objects (including static libraries)