Package: planner / 0.14.6-7

Metadata

Package Version Patches format
planner 0.14.6-7 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
704171 fix print preview crash.patch | (download)

src/planner-print-job.c | 14 1 + 13 - 0 !
1 file changed, 1 insertion(+), 13 deletions(-)

 fix crash on print preview of empty document


desktop validate.patch | (download)

data/planner.desktop.in.in | 12 8 + 4 - 0 !
1 file changed, 8 insertions(+), 4 deletions(-)

 fix .desktop file validation
 Fix problems revealed by "desktop-file-validate".


dependant_typo.diff | (download)

po/eo.po | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 this patch fixes a typo in planner
 (perhaps need to be forwarded again, this is the only typo left since
  last release)


plugins_directory.diff | (download)

libplanner/Makefile.am | 10 5 + 5 - 0 !
src/Makefile.am | 2 1 + 1 - 0 !
2 files changed, 6 insertions(+), 6 deletions(-)

 the configure's --libdir parameter is used to comply with
 Debian Policy 10.2 which states that not public libraries should be
 installed in subdirectories of /usr/lib. This patch was added in
 order to keep the *-modules and plugins directories in the right
 place.
command_line_args.diff | (download)

src/planner-main.c | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 planner is unable to read files from command line.
 This patch solves the issue.
fix as needed build.patch | (download)

src/Makefile.am | 2 1 + 1 - 0 !
tests/Makefile.am | 14 7 + 7 - 0 !
2 files changed, 8 insertions(+), 8 deletions(-)

 fix build with "ld --as-needed", without required "-lm".
 libraries must be behind objects (including static libraries)


gtk doc 1.26.patch | (download)

docs/libplanner/Makefile.am | 136 1 + 135 - 0 !
gtk-doc.make | 321 321 + 0 - 0 !
2 files changed, 322 insertions(+), 135 deletions(-)

 use gtk-doc.make to fix ftbfs with gtk-doc 1.26
python plugin crash.patch | (download)

src/planner-python-plugin.c | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 fix crash when executing python scripts.
no scrollkeeper.patch | (download)

configure.in | 9 0 + 9 - 0 !
docs/user-guide/C/Makefile.am | 2 1 + 1 - 0 !
docs/user-guide/eu/Makefile.am | 2 1 + 1 - 0 !
3 files changed, 2 insertions(+), 11 deletions(-)

 eliminate scrollkeeper dependency.
 Upstream is moving to yelp-tools; patches are available but not yet
 committed: https://bugzilla.gnome.org/show_bug.cgi?id=346247
no libgnomeui.patch | (download)

configure.in | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 remove libgnomeui dependency.
Bug-Debian: https://bugs.debian.org/888857
document help option.patch | (download)

docs/user-guide/C/planner.xml | 13 6 + 7 - 0 !
1 file changed, 6 insertions(+), 7 deletions(-)

 document the --help option in the manual.
Bug-Debian: https://bugs.debian.org/675794
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=679714
pkg config detection.patch | (download)

configure.in | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 use pkg_prog_pkg_config to detect pkg-config.
gsettings port.patch | (download)

configure.in | 13 2 + 11 - 0 !
data/Makefile.am | 19 6 + 13 - 0 !
data/org.gnome.Planner.gschema.xml | 434 434 + 0 - 0 !
data/planner.convert | 170 170 + 0 - 0 !
data/planner.schemas.in | 90 0 + 90 - 0 !
po/POTFILES.in | 3 2 + 1 - 0 !
src/planner-conf-gconf.c | 138 68 + 70 - 0 !
src/planner-conf.h | 21 10 + 11 - 0 !
src/planner-gantt-chart.c | 18 9 + 9 - 0 !
src/planner-gantt-view.c | 48 4 + 44 - 0 !
src/planner-main.c | 76 76 + 0 - 0 !
src/planner-msp-plugin.c | 15 11 + 4 - 0 !
src/planner-print-dialog.c | 32 23 + 9 - 0 !
src/planner-resource-view.c | 44 5 + 39 - 0 !
src/planner-task-tree.c | 2 1 + 1 - 0 !
src/planner-task-view.c | 72 10 + 62 - 0 !
src/planner-usage-tree.c | 4 2 + 2 - 0 !
src/planner-usage-view.c | 40 2 + 38 - 0 !
src/planner-view.c | 62 27 + 35 - 0 !
src/planner-view.h | 6 4 + 2 - 0 !
src/planner-window.c | 84 32 + 52 - 0 !
src/planner-xml-planner-plugin.c | 14 10 + 4 - 0 !
22 files changed, 908 insertions(+), 497 deletions(-)

 migrate from gconf to gsettings.