Package: plexus-compiler / 1.9.2-2

Metadata

Package Version Patches format
plexus-compiler 1.9.2-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix_test_classpath.patch | (download)

plexus-compiler-test/src/main/java/org/codehaus/plexus/compiler/AbstractCompilerTest.java | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
eclipse compatibility.patch | (download)

plexus-compilers/plexus-compiler-eclipse/src/main/java/org/codehaus/plexus/compiler/eclipse/EclipseJavaCompiler.java | 5 5 + 0 - 0 !
1 file changed, 5 insertions(+)

 preserves the compatibility with the version of the eclipse
 compiler available in Debian. This patch will become obsolete when upgrading
  plexus-compiler to 2.1 or later.
backward compatibility.patch | (download)

plexus-compilers/plexus-compiler-javac/src/main/java/org/codehaus/plexus/compiler/javac/JavacCompiler.java | 5 5 + 0 - 0 !
1 file changed, 5 insertions(+)

 fixes an incompatibility introduced in plexus-compiler 1.8.1 and
 affecting maven-stapler-plugin. This patch can be dropped after upgrading
 maven-stapler-plugin to 1.17 or later.
set dependencies versions.patch | (download)

plexus-compiler-api/pom.xml | 3 3 + 0 - 0 !
plexus-compilers/plexus-compiler-javac/pom.xml | 1 1 + 0 - 0 !
plexus-compilers/pom.xml | 1 1 + 0 - 0 !
3 files changed, 5 insertions(+)

 specifies the missing versions of the dependencies.
 The versions are actually specified in a parent pom that is not available
 in Debian, and for some reason the Maven rules don't work to substitute
 these versions automatically.