Package: puppet-module-puppetlabs-rabbitmq / 5.3.1-5

Metadata

Package Version Patches format
puppet-module-puppetlabs-rabbitmq 5.3.1-5 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
do not download rabbitmqadmin in debian.patch | (download)

lib/puppet/provider/rabbitmq_queue/rabbitmqadmin.rb | 4 2 + 2 - 0 !
manifests/init.pp | 12 9 + 3 - 0 !
2 files changed, 11 insertions(+), 5 deletions(-)

 do not download rabbitmqadmin in debian
fix LANG problem in provider.patch | (download)

lib/puppet/provider/rabbitmq_binding/rabbitmqadmin.rb | 5 3 + 2 - 0 !
lib/puppet/provider/rabbitmq_exchange/rabbitmqadmin.rb | 5 3 + 2 - 0 !
lib/puppet/provider/rabbitmq_plugin/rabbitmqplugins.rb | 6 4 + 2 - 0 !
lib/puppet/provider/rabbitmq_queue/rabbitmqadmin.rb | 6 4 + 2 - 0 !
lib/puppet/provider/rabbitmq_user/rabbitmqctl.rb | 3 2 + 1 - 0 !
lib/puppet/provider/rabbitmq_user_permissions/rabbitmqctl.rb | 5 3 + 2 - 0 !
lib/puppet/provider/rabbitmq_vhost/rabbitmqctl.rb | 3 2 + 1 - 0 !
7 files changed, 21 insertions(+), 12 deletions(-)

 fix $lang problem in provider
 If $LANG isn't set, rabbitmqctl produces a bad warning which prevents
 setting-up rabbit credentials. This only happen with recent versions of
 rabbitmq and elixir.
 .
 To work around this, the lib/puppet/provider scripts set the $LANG
 environment variable to en_US.UTF-8. Also, in
 lib/puppet/provider/rabbitmq_user_permissions/rabbitmqctl.rb, as it looked
 like not enough, the script is grep-ing the warning out.
fix old definition of repo in apt.pp.patch | (download)

manifests/repo/apt.pp | 3 0 + 3 - 0 !
1 file changed, 3 deletions(-)

 fix old definition
 The current code wouldn't compile, this fixes it.