Package: pycuda / 2020.1~dfsg1-1

python3.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Description: Run scripts under Python 3
 Ensure that setup.py and configure.py uses Python 3 for running.
Forwarded: not-needed
Author: Tomasz Rybak <serpent@debian.org>
Last-Update: 2019-11-06

--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
 # -*- coding: utf-8 -*-
 
 from __future__ import absolute_import, print_function
--- a/examples/download-examples-from-wiki.py
+++ b/examples/download-examples-from-wiki.py
@@ -1,4 +1,4 @@
-#! /usr/bin/env python
+#! /usr/bin/env python3
 from __future__ import print_function, absolute_import
 try:
     import six.moves.xmlrpc_client
--- a/test/test_gpuarray.py
+++ b/test/test_gpuarray.py
@@ -1,4 +1,4 @@
-#! /usr/bin/env python
+#! /usr/bin/env python3
 
 from __future__ import absolute_import, print_function
 import numpy as np