Package: pykde4 / 4:4.8.4-1

Metadata

Package Version Patches format
pykde4 4:4.8.4-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
python_modules_dont_link_against_libpython.diff | (download)

CMakeLists.txt | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 do not let python modules link against libpython.
add_qt_kde_definitions.diff | (download)

CMakeLists.txt | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 define qt/kde definitions when building standalone
fix_kpythonpluginfactory_build.diff | (download)

kpythonpluginfactory/kpythonpluginfactory.cpp | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 include python.h first as qt includes steal "slots" keyword
make_pykde4_respect_sip_flags.diff | (download)

CMakeLists.txt | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 respect qt sip flags
pythonpluginfactory_use_versioned_python_lib.diff | (download)

kpythonpluginfactory/kpythonpluginfactory.cpp | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 make kpythonfactory dlopen versioned python library.
Bug-Debian: http://bugs.debian.org/524685
Bug-Debian: http://bugs.debian.org/541999
optional_install_sip_files.diff | (download)

CMakeLists.txt | 17 11 + 6 - 0 !
1 file changed, 11 insertions(+), 6 deletions(-)

 install sip files only when building for default python version