Package: pynast / 1.2.2-2

Metadata

Package Version Patches format
pynast 1.2.2-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
do_not_install_privacy_breaching_scripts.patch | (download)

doc/_static/google_feed.js | 28 0 + 28 - 0 !
doc/_templates/layout.html | 6 0 + 6 - 0 !
2 files changed, 34 deletions(-)

 do not install privacy breaking scripts


skip_tests_needing_uclust.patch | (download)

tests/test_pycogent_backports/test_uclust.py | 291 0 + 291 - 0 !
tests/test_util.py | 359 1 + 358 - 0 !
2 files changed, 1 insertion(+), 649 deletions(-)

 debian can not package uclust for licensing reasons - skip tests
 requiring uclust


avoid_python mpi4py_missing_warning.patch | (download)

tests/all_tests.py | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 since we are not building with python-mpi4py (there is other
 trouble occuring with this as Build-Depends) we need to strip the warning
 from script output to make the test successfully passing


accommodate_blast+.patch | (download)

pynast/util.py | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

 adapt to the modern blast engine and blast+ legacy_blast wrapper.
* Specify an explicit gap extension cost (2) to accompany the explicit
  mismatch penalty.
* Reduce the word size to the traditional value of 11 so the test
  cases can succeed.
* Stop trying to request the old engine.
* Accommodate minor output format changes between legacy BLAST and
  BLAST+.