Package: pynpoint / 0.8.3-3

pipv20-compat Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
Description: <short summary of the patch>
 TODO: Put a short summary on the line above and replace this paragraph
 with a longer explanation of this change. Complete the meta-information
 with other relevant fields (see below for details). To make it easier, the
 information below has been extracted from the changelog. Adjust it or drop
 it.
 .
 pynpoint (0.8.3-1) unstable; urgency=medium
 .
   * New upstream version.
   * Bump standards version to 4.5.0.
Author: G├╝rkan Myczko <gurkan@phys.ethz.ch>

---
The information above should follow the Patch Tagging Guidelines, please
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
are templates for supplementary fields that you might want to add:

Origin: <vendor|upstream|other>, <url of original patch>
Bug: <url in upstream bugtracker>
Bug-Debian: https://bugs.debian.org/<bugnumber>
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
Forwarded: <no|not-needed|url proving that it has been forwarded>
Reviewed-By: <name and email of someone who approved the patch>
Last-Update: 2020-05-24

--- pynpoint-0.8.3.orig/setup.py
+++ pynpoint-0.8.3/setup.py
@@ -2,13 +2,11 @@
 
 from setuptools import setup
 
-try:
-    from pip._internal.req import parse_requirements
-except ImportError:
-    from pip.req import parse_requirements
+from pip._internal.network.session import PipSession
+from pip._internal.req import parse_requirements
 
-reqs = parse_requirements('requirements.txt', session='hack')
-reqs = [str(ir.req) for ir in reqs]
+reqs = parse_requirements('requirements.txt', session=PipSession())
+reqs = [str(req.requirement) for req in reqs]
 
 setup(
     name='pynpoint',