Package: python-cogent / 1.9-14

raxml_unsupported_version.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Author: Andreas Tille <tille@debian.org>
Last-Update: Thu, 21 May 2015 08:47:01 +0200
Description: The test is checking for an old version of raxml
 for no good reason

--- a/tests/test_app/test_raxml_v730.py
+++ b/tests/test_app/test_raxml_v730.py
@@ -43,7 +43,8 @@ class GenericRaxml(TestCase):
         version_string = stdout.strip().split(' ')[4].strip()
         try:
             version = tuple(map(int,version_string.split('.')))
-            pass_test = version == acceptable_version
+# Debian has later versions than 7.3.0 and checking only a fixed version makes no sense at all
+#            pass_test = version == acceptable_version
         except ValueError:
             pass_test = False
             version_string = stdout