Package: python-django-piston / 0.2.3-2

Metadata

Package Version Patches format
python-django-piston 0.2.3-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01 fix oauth import.diff | (download)

piston/authentication.py | 2 1 + 1 - 0 !
piston/store.py | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 fix the oauth import to work correctly with the
 python-oauth Debian package.
02 correct httpresponse.patch | (download)

piston/resource.py | 23 18 + 5 - 0 !
piston/utils.py | 28 18 + 10 - 0 !
2 files changed, 36 insertions(+), 15 deletions(-)

 use _base_content_is_iter or _is_string
 Correctly use _base_content_is_iter or _is_string on HttpResponse depending on
 Django version.
03 django1.4 support.patch | (download)

piston/resource.py | 6 3 + 3 - 0 !
piston/tests.py | 4 3 + 1 - 0 !
tests/test_project/settings.py | 7 7 + 0 - 0 !
3 files changed, 13 insertions(+), 4 deletions(-)

 piston now supports django 1.4
 Support for Django 1.4
04 json compat django1.5.patch | (download)

piston/emitters.py | 15 12 + 3 - 0 !
1 file changed, 12 insertions(+), 3 deletions(-)

 compatibility fix for json emitter with django 1.5
 Fixes compatibility with Django 1.5 to use json instead of
 simplejson due to deprecation.
05 compat django1.5 httpresponsewrapper.patch | (download)

piston/utils.py | 10 9 + 1 - 0 !
1 file changed, 9 insertions(+), 1 deletion(-)

 added compatibility with django v1.5 for httpresponsewrapper class
 Add compatibility for django 1.5 due to HttpResponse._get_content
 not existing in Django 1.5
06 django1.6 wsgirequest compat.patch | (download)

piston/utils.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 compatibility fix for wsgirequest with django 1.6
 Fixes compatibility with Django 1.6 to return the correct
 data on a WSGIRequest.