Package: python-fabio / 0.8.0+dfsg-1

0002-fix-the-install_requires-depends.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
From: =?utf-8?q?Picca_Fr=C3=83=C2=A9d=C3=83=C2=A9ric-Emmanuel?=
 <picca@synchrotron-soleil.fr>
Date: Thu, 7 Sep 2017 14:33:43 +0200
Subject: fix the install_requires depends

---
 setup.py | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index ae6dc12..abe7442 100644
--- a/setup.py
+++ b/setup.py
@@ -864,7 +864,15 @@ def get_project_configuration(dry_run):
         # for most of the computation
         "numpy",
         # for the script launcher
-        "setuptools"]
+        "setuptools",
+        # for debian
+        "h5py",
+        "lxml",
+        "matplotlib",
+        "pil",
+        "PyQt5",
+        "six"
+    ]
 
     setup_requires = ["setuptools", "numpy", "cython"]