Package: python-hacking / 0.11.0-2.1~deb9u1

Metadata

Package Version Patches format
python-hacking 0.11.0-2.1~deb9u1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix requirements.txt.patch | (download)

requirements.txt | 6 3 + 3 - 0 !
1 file changed, 3 insertions(+), 3 deletions(-)

 allow greater versions for both pep8, flake8, pyflakes and mccabe
 Also support flake8 >= 2.2.2
flake8 legacy.patch | (download)

hacking/core.py | 10 5 + 5 - 0 !
hacking/tests/test_doctest.py | 16 9 + 7 - 0 !
hacking/tests/test_local.py | 13 8 + 5 - 0 !
requirements.txt | 4 2 + 2 - 0 !
4 files changed, 24 insertions(+), 19 deletions(-)

 compatibility patch for distro mis-alignment with upstream.
 flake8 >= 3 moved the engine API to legacy
 Skip tets as flake8 and pycodestyle don't want to
 work in the same way as flake8 and pep8 did in the
 past, and there is no stable API to write something
 new against.