Package: python-mkdocs / 1.0.4+dfsg-1

Metadata

Package Version Patches format
python-mkdocs 1.0.4+dfsg-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Use themes from usr share mkdocs themes.patch | (download)

mkdocs/__init__.py | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

 use themes from /usr/share/mkdocs/themes

See https://lists.debian.org/debian-python/2016/04/msg00042.html

0002 Remove privacy breaches.patch | (download)

mkdocs.yml | 1 0 + 1 - 0 !
mkdocs/themes/mkdocs/base.html | 5 0 + 5 - 0 !
mkdocs/themes/readthedocs/base.html | 2 0 + 2 - 0 !
3 files changed, 8 deletions(-)

 remove privacy breaches

- Disable Google Analytics in mkdocs-doc.
- Disable scripts from third-party websites.

0003 Disable use_directory_urls configuration option.patch | (download)

mkdocs.yml | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 disable use_directory_urls configuration option

To make it easier to browse the documentation locally.

0004 Add .md files to the MANIFEST.patch | (download)

MANIFEST.in | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 add *.md files to the manifest

Without this, 'setup.py build' does not copy them to the build
directory, and some tests are failing.

0005 Disable the Markdown GitHub links extension.patch | (download)

mkdocs.yml | 3 0 + 3 - 0 !
1 file changed, 3 deletions(-)

 disable the markdown github links extension

Until it is packaged in Debian.

0006 Do not assert that fonts directory exists.patch | (download)

mkdocs/tests/build_tests.py | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 do not assert that fonts directory exists

We exclude that directory when building the DFSG tarball, and replace
the fonts with symlinks to packaged versions.

0007 Disable non English search support.patch | (download)

docs/user-guide/configuration.md | 44 0 + 44 - 0 !
mkdocs/contrib/search/prebuild-index.js | 14 0 + 14 - 0 !
mkdocs/tests/search_tests.py | 2 2 + 0 - 0 !
3 files changed, 2 insertions(+), 58 deletions(-)

 disable non-english search support

The lunr-languages library is unmaintained and incompatible with the
latest version of lunr, which we are going to use.